using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"q$|^w";
string input = @"weekend
hello
yummy
working
seq
sequence
bird
puzzle
wholesome";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}