package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)q$|^w`)
var str = `weekend
hello
yummy
working
seq
sequence
bird
puzzle
wholesome`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}