$re = '/^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?/m';
$str = 'D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);