import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"[^\"]*(?<=\"|\\s)description_quote(?=\"|\\s[^\"]*)\">[^>]*>(?<description>[^<]*)";
final String string = " <div class=\"col-xs-12 description\"> <h3>Seller Says</h3> <div class=\"row\"> <div class=\"col-xs-12 description\"> <blockquote class=\"description_quote\"> <p itemprop=\"description\"> Kasut Futsal Nike Untuk Dijual Size 9 Baru Pakai Sekali...Nak jual sebab dah stop futsal...Minat Wsap/Call 0139343829Letak Harga 110 Nego sampai jual...Cod Kuantan Sahaja..No post. </p> </blockquote> </div> </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}