const regex = new RegExp('class="[^"]*(?<="|\\s)description_quote(?="|\\s[^"]*)">[^>]*>(?<description>[^<]*)', 'gmis')
const str = ` <div class="col-xs-12 description"> <h3>Seller Says</h3> <div class="row"> <div class="col-xs-12 description"> <blockquote class="description_quote"> <p itemprop="description"> Kasut Futsal Nike Untuk Dijual Size 9 Baru Pakai Sekali...Nak jual sebab dah stop futsal...Minat Wsap/Call 0139343829Letak Harga 110 Nego sampai jual...Cod Kuantan Sahaja..No post. </p> </blockquote> </div> </div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}