$re = '/<p>(.*?)<\/p>\n*[<p><\/p>]{1}/mi';
$str = '<p>Вы бы хотели иметь возможность заглянуть в будущее? </p>
<p></p>
<p>Некоторым удалось.. </p>
<p></p>
<p></p>
<p></p>
<p>Бла-бла</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);