using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[{2}{""value"":""(.*?)""";
string input = @"[[{""value"":""Site Name""}]]AAAAAAAA[[{""value"":""Site Name""}]]BBBB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}