$re = '/\b(wood.*?)\b/i';
$str = 'wood and stuff
this doesnt contain the keyword
Wooding is what we do';
$subst = "<span class=\"highlight\">\1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;