^start of line
\d+?a digit, repeated at least once
\sany whitespace character
\d+?a digit, repeated at least once
\sany whitespace character
.+?any character (except for line terminators), repeated at least once
\sany whitespace character
.+?any character (except for line terminators), repeated at least once
\sany whitespace character
.+?any character (except for line terminators), repeated at least once
\sany whitespace character
.*?any character (except for line terminators), repeated any number of times
\.the literal . (4610 / 568 / 2E16)
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string