re = /^(?!ignoreme2?$).*$/m
str = 'ignoreme
ignoreme2
ignoremex
ignorem
gnoreme
ignoreme22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end