using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*(.*?\[[^][]*])";
string input = @"i want to show you my youtube channel : [youtube id=12341234] and my instagram account : [instagram id=myingaccount213]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}