re = /\h*(.*?\[[^][]*])/m
str = 'i want to show you my youtube channel : [youtube id=12341234] and my instagram account : [instagram id=myingaccount213]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end