use strict;
my $str = 'SELECT
di.QuestionSetID AS SectionID,
,di.ScoreNBR AS Section,LowestTopBoxNBR
,di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR
,qdate.Quarter,StartDTS AS Section,StartDTS
FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di
INNER JOIN (
asdf,,asdf,
,ll
,,,,,,
,,';
my $regex = qr/(.),(.)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";