// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bDELIVER TO:\r?\n{2}[ \t]*(\S+).*(?:\r?\n.*){4}.*[ \t](\S+)").unwrap();
let string = "RECOVER FROM:
Company 1
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla
DELIVER TO:
Sypris Solutions, Inc.
Street 123
City ZIP US
Bla: Bla
Bla: Bla
Bla: Bla";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}