#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^JML\s*\|.*\s*\r?\n((?:.*\r?\n)*?)Authors\b"
Local $sString = "--- JOURNAL of MEDICINE and LIFE" & @CRLF & _
"" & @CRLF & _
"JML | REVIEW" & @CRLF & _
"" & @CRLF & _
"The role of novel poly (ADP-ribose) inhibitors in the treatment of locally advanced and metastatic Her-2/neu negative breast cancer with inherited germline BRCA1/2 mutations. A review of the literature" & @CRLF & _
"" & @CRLF & _
"Authors list, etc, etc ---" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")