package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^JML\s*\|.*\s*\r?\n((?:.*\r?\n)*?)Authors\b`)
var str = `--- JOURNAL of MEDICINE and LIFE
JML | REVIEW
The role of novel poly (ADP-ribose) inhibitors in the treatment of locally advanced and metastatic Her-2/neu negative breast cancer with inherited germline BRCA1/2 mutations. A review of the literature
Authors list, etc, etc ---
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}