const regex = /^JML\s*\|.*\s*\r?\n((?:.*\r?\n)*?)Authors\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^JML\\s*\\|.*\\s*\\r?\\n((?:.*\\r?\\n)*?)Authors\\b', 'gm')
const str = `--- JOURNAL of MEDICINE and LIFE
JML | REVIEW
The role of novel poly (ADP-ribose) inhibitors in the treatment of locally advanced and metastatic Her-2/neu negative breast cancer with inherited germline BRCA1/2 mutations. A review of the literature
Authors list, etc, etc ---
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}