import re
regex = re.compile(r"^[a-zA-Z0-9-]+:[ a-zA-Z0-9()'\"-_.]+;\s?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("border-bottom-color: coral;\n"
"column-rule: 4px double #ff00ff;\n"
"grid-area: 2 / 1 / span 2 (00)/ span 3;\n"
"list-style: square inside url(\"sqpurple.gif\");\n"
"object-position: 5px 10%;\n"
"border: 5px solid red;\n"
"background-color: hsla(89, 43%, 51%, 0.3);\n"
"font-variant-caps: all-small-caps;\n"
"background-image: url('img_tree.gif'), url(\"paper.gif\");\n"
"width: calc(var(--variable-width) + 20px);\n"
"width: calc(2em *+- 5);\n"
"grid-template-columns: 1fr fit-content(250px);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")