re = /^(\d+)\h+-\h+\1$/m
str = '9993990487 - 9993990487
9993990553 - 9993990553
9993990554 - 9993990559
9993990570 - 9993990570
9993990593 - 9993990596
9993990594 - 9993990594'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result