using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([\!|\$])([\w]{1,15}))((?:,)([\w.\-\+]{0,20})){1,20}(?:,){0,1}(?:\*){0,1}([A-F0-9]{2}){0,1}";
string input = @"Timestamped NMEA:
2021-03-03 23:19:17 $HCHDM,004.90,M*14
2021-03-03 23:19:17 $GPVTG,358.7,T,1.6,M,15.005,N,27.789,K,A*2F
2021-03-03 23:19:17 $HEHDT,001.71,T*18
2021-03-03 23:19:17 $PPLAN,,,,,,,,2*71
2021-03-03 23:19:17 $GPDTM,W84,,00.0000,N,00.0000,E,,W84*41
2021-03-03 23:19:17 $SDDBT,0101.0,f,0030.8,M,016.8,F*02
2021-03-03 23:19:17 $HEHDT,001.70,T*19
2021-03-03 23:19:17 $HCHDM,004.80,M*15
2021-03-03 23:19:17 $PESSA,1.7,1.7,1.7,0.01,P,0.00,S,0.0,S,2000,*2D
2021-03-03 23:19:17 $SDDPT,0030.8,0011.5,40*71
2021-03-03 23:19:17 $HEHDT,001.70,T*19
2021-03-03 23:19:17 $TIROT,-0000.2,A*24
2021-03-03 23:19:17 $PESSD,8.7,D,1.80,N,14.8,N,,,H,L,G,I,C,0A00,2000,0002*08
2021-03-03 23:19:17 $GPGGA,231916.00,2204.6412,N,11437.4255,E,1,10,0.8,34.3,M,-0.5,M,,*44
2021-03-03 23:19:17 $GPDTM,W84,,00.0000,N,00.0000,E,,W84*41
2021-03-03 23:19:17 $PFEC,Alarm,0,0*6F
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}