package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d{0,2}(\.\d{3})*,\d{2}$`)
var str = `99999A123
7.300.250,00
21.000,00
123,12
01,12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}