const regex = new RegExp('^[1-9]\\d{0,2}(\\.\\d{3})*,\\d{2}$', 'gm')
const str = `99999A123
7.300.250,00
21.000,00
123,12
01,12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}