$re = '/^[1-9]\d{0,2}(\.\d{3})*,\d{2}$/m';
$str = '99999A123
7.300.250,00
21.000,00
123,12
01,12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);