re = /^[1-9]\d{0,2}(\.\d{3})*,\d{2}$/m
str = '99999A123
7.300.250,00
21.000,00
123,12
01,12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end