import re
regex = re.compile(r":\D{8}\d{2}", flags=re.MULTILINE)
test_str = ("1:nlcbjduy14 <- I want regex to find this one \n"
"2:Peoples123 <- I don't want regex to find this one, as it has 3 digits.\n"
"3:sqourzyr17 <- I want regex to find this one\n"
"4:rdmaszgr94 <- I want regex to find this one\n"
"5:tnwiudic22 <- I want regex to find this one\n"
"6:zfcxmkrs21 <- I want regex to find this one\n"
"7:xrwhsgno55 <- I want regex to find this one\n"
"8:modtwtrr06 <- I want regex to find this one\n"
"9:People123 <- I don't want regex to find this one, as it is isn't 10 chars long and it consists of 3 digits.\n"
"10:aetmyqqh52 <- I want regex to find this one\n"
"11:Howtocodelikeapro12 <- I don't want regex to find this one, as it is isn't 10 chars long\n"
"12:netphvib58 <- I want regex to find this one\n"
"13:uwyiqhoj29 <- I want regex to find this one\n"
"14:RegexJustiIsntDoingItForMe\n"
"15:qyeiaecj27 <- I want regex to find this one\n"
"16:buttercake <- I don't want regex to find this one, as it doesn't end with 2 digits.\n"
"17:bcyiyjdm23 <- I want regex to find this one\n"
"18:Differings <- I don't want regex to find this one, as it doesn't end with 2 digits.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")