#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^XXX-\d{4}-((?![XYT])[A-Z]){4}$"
Local $sString = "XXX-0000-XBCD" & @CRLF & _
"XXX-0000-AXCD" & @CRLF & _
"XXX-0000-ABXD" & @CRLF & _
"XXX-0000-ABCX" & @CRLF & _
"XXX-0000-XXCD" & @CRLF & _
"XXX-0000-XBXD" & @CRLF & _
"XXX-0000-XBCX" & @CRLF & _
"XXX-0000-AXXD" & @CRLF & _
"XXX-0000-AXCX" & @CRLF & _
"XXX-0000-ABXX" & @CRLF & _
"XXX-0000-XXXX" & @CRLF & _
"XXX-0000-AB1D" & @CRLF & _
"XXX-0000-A%CD" & @CRLF & _
"XXX-0000-ABCDE" & @CRLF & _
"XXX-0000-ABCDX" & @CRLF & _
"AXXX-0000-ABCD" & @CRLF & _
"XXX-A0000-ABCD" & @CRLF & _
"XXX-0000-ABCD" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")