^start of line
*repeats the group contents below any number of times:
https:the literal text https: (case sensitive) \/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
Group 2(localhost|airhelp.com) localhostthe literal text localhost (case sensitive) 2nd Alternativeairhelp.com airhelpthe literal text airhelp (case sensitive) .any character (except for line terminators)
comthe literal text com (case sensitive) \/the literal / (4710 / 578 / 2F16)
Negative Lookahead(?!en|nl|pt) enthe literal text en (case sensitive) nlthe literal text nl (case sensitive) ptthe literal text pt (case sensitive) .*any character (except for line terminators), repeated any number of times
\/the literal / (4710 / 578 / 2F16)
.*any character (except for line terminators), repeated any number of times
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string