re = /^(?:https?:\/\/)?(?:www\.)?(?:.+?)\.mp4$/i
str = 'http://commondatastorage.googleapis.com/gtv-videos-bucket/sample/ForBiggerFun.mp4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end