re = /^\S+@\w+\.\w+$/m
str = 'example@example.com
example@gmail.com
example@example.co.fr
john@smith.org
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end