$re = '/^(?!.* |.*\'|.*"|.*666).+/m';
$str = 'foo
bar
baz
bazz\'
buzz66
buzz666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);