const regex = /<pop title="([a-zA-Z0-9]+)">dolor<\/pop>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<pop title="([a-zA-Z0-9]+)">dolor<\\\/pop>', 'gm')
const str = `<p><pop title="test">Lorem</pop> ipsum <pop title="dekisha">dolor</pop> sit amet, adipiscing <pop title="test">dolor</pop> elit. Cras at aliquam enim. Curabitur nisi nunc, tincidunt et efficitur ut, finibus eu arcu. Maecenas aliquam nisl sed erat ultrices venenatis. Orci varius natoque <pop title="test">dolor</pop> penatibus <pop title="test">dolor</pop> et magnis dis parturient montes, nascetur ridiculus mus. In sed semper nisi. Ut quis sapien pharetra, volutpat arcu id, mollis lacus. Duis lacus dui, laoreet ac rutrum non, aliquam sit amet mi. Donec a quam ut tortor ornare mattis et a dui. Mauris non mauris est. Etiam arcu ante, condimentum mattis cursus ac, vestibulum quis nulla. Etiam vehicula, arcu ac pretium feugiat, tellus eros pellentesque quam, at pulvinar ligula turpis eget lectus. Phasellus vitae turpis augue.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}