# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<pop title=\"([a-zA-Z0-9]+)\">dolor<\/pop>"
test_str = "<p><pop title=\"test\">Lorem</pop> ipsum <pop title=\"dekisha\">dolor</pop> sit amet, adipiscing <pop title=\"test\">dolor</pop> elit. Cras at aliquam enim. Curabitur nisi nunc, tincidunt et efficitur ut, finibus eu arcu. Maecenas aliquam nisl sed erat ultrices venenatis. Orci varius natoque <pop title=\"test\">dolor</pop> penatibus <pop title=\"test\">dolor</pop> et magnis dis parturient montes, nascetur ridiculus mus. In sed semper nisi. Ut quis sapien pharetra, volutpat arcu id, mollis lacus. Duis lacus dui, laoreet ac rutrum non, aliquam sit amet mi. Donec a quam ut tortor ornare mattis et a dui. Mauris non mauris est. Etiam arcu ante, condimentum mattis cursus ac, vestibulum quis nulla. Etiam vehicula, arcu ac pretium feugiat, tellus eros pellentesque quam, at pulvinar ligula turpis eget lectus. Phasellus vitae turpis augue.</p>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.