$re = '@\[(\[?)(.*?)(?![\w-])([^\]/]*(?:/(?!\])[^\]/]*)*?)(?:(/)\]|\](?:([^\[]*(?:\[(?!/\2\])[^\[]*)*)(\[/\2\]))?)(\]?)@';
$str = 'This is a test [example attr1="test1" attr2="test2"]content
over multiple
lines with a random[shortcode] inside[/example]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);