using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({(.*?(,??)""(Name)"":""(.*?)""|""(.*?)"":""(.*?)"")})";
string input = @"{""ID"":""123"",""Name"":""ABC""},{""ID"":""234"",""Name"":""BCD""},{""ID"":""345"",""Name"":""DEF""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}