use strict;
my $str = '23,560
1289,4
1,9
63478,1252
0,3265
086,344
34,7000
-0,2
-333,44
-33,550
-44.66
-0.005
0,66
-0
0
55';
my $regex = qr/^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}