using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)";
string input = @"Port Name Status Vlan Duplex Speed Type
Te1/1.5 disabled 1 full 10G 10Gbase-LX4
Te1/2 disabled 1 full 10G 10Gbase-LX4
Te1/3 disabled 1 full 10G 10Gbase-LR
Te1/4 disabled 1 full 10G 10Gbase-LX4
Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX
Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}