package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2}))\.){3}(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2})))$`)
var str = `1.1.1.1
254.2.2.2.
255.1.1.255
256.1.1.256
012.111.111.111
12.12.12.12a
1q.1.1.1
1.1q.1.1
1.1.1q.1
1.1.1.1q
abcde254.2.2.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}