re = /^(?=\d{9}$)\d*(\d\d)\1{3}\d*$/m
str = '561616161
121212123
411111111
111111114
111111111
299887766
887756564
123412345
123123123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end