$re = '/((\+|\(|0)?\d{1,3})?((\s|\)|\-))?(\d{10})$/m';
$str = '+91 7258554692
07258554692
7288554692
(91)7258554692
+917258554692
917258554692
+91-7258554692
+7627208551923
----
2323
++912305225356
1254686599542212555
cdsafdf3221312
725a554692';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);