# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\+|\(|0)?\d{1,3})?((\s|\)|\-))?(\d{10})$"
test_str = ("+91 7258554692\n"
"07258554692\n"
"7288554692\n"
"(91)7258554692\n"
"+917258554692\n"
"917258554692\n"
"+91-7258554692\n"
"+7627208551923\n"
"----\n"
"2323\n"
"++912305225356\n"
"1254686599542212555\n"
"cdsafdf3221312\n"
"725a554692")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.