package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s*(1st|2d)($|\W).*`)
var str = `covid19 1st case
covid19 2d case
covid19 1std 1st case`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}