// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)amount:(\d+[,.]\d+(?:[.,]\d+)?)").unwrap();
let string = "el amount:762,50 es
1.843,75
1,75";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}