using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?<!\\\\)=";
string input = @"metadata=1.2 name=ston\\=e:su pershare UUID=eff4e7bc:47aea5cf:0f0560f0:2de38475";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}