re = /\[((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?((\w+)\s?)?\]/
str = '[bad column name]
[bad column]
[very very bad column name]
'
subst = '[$2$4$6$8$10]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result