# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^:\r\n]+:\h*(.*)/\1/gm;t' <<< "afghanistan : Afghanistan
albania : Albania
algeria : Algeria
andorra : Andorra
angola : Angola"