// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^:\r\n]+:\h*(.*)").unwrap();
let string = "afghanistan : Afghanistan
albania : Albania
algeria : Algeria
andorra : Andorra
angola : Angola";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}