using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:(.*)";
string substitution = @"https:$1";
string input = @"http://mmc.com/events";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}