$re = '/^http:(.*)/';
$str = 'http://mmc.com/events';
$subst = "https:$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;