// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^http:(.*)").unwrap();
let string = "http://mmc.com/events";
let substitution = "https:$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}