import Foundation
let pattern = #"f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}